PHP is amongst the most widely used multiparadigm programming languages. It is very popular as it’s free software, which can be used to create responsive websites such as social networking sites, online shops or e-teaching portals instead of static HTML websites. A PHP module should be enabled on the web server where a PHP site is hosted so that its source code can be ‘decrypted’. As there aren’t any license fees for this type of module and the language provides innumerable options for the apps that you build, there are 100s of millions of PHP-driven sites. On top of that, there are tons of PHP scripts, which you can use for your websites without the need to have any coding experience. Considering the fact that there are a number of PHP versions, you should confirm whether the same exact version that you used while developing your website is enabled on the server too.

PHP 4, PHP 5 and PHP 7 Support in Shared Web Hosting

Our shared web hosting servers support several PHP versions, which suggests that your websites will run without any problem no matter if your PHP-based scripts are out of date. We realize that an old site doesn’t necessarily mean an insecure one as you may have carried out a lot of code mods. That is the reason why we support PHP 4, PHP 5 and PHP 7 and you can pick which version will be enabled for your shared web hosting account. You can change the version with one mouse click within your Hepsia hosting Control Panel and the update will take effect instantaneously. If you would like to run both older and newer scripts, there is even an option to use a different version of PHP for each domain name of yours simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

If you’ve got a site built with an older PHP version and you’ve spent time and efforts on developing it, filling safety holes and inserting page content, you will need to find a hosting service that can support it, since the vast majority of hosting vendors these days offer support only for the most recent version of PHP and abandon the previous versions. We, on the other hand, have decided to allow you to choose the exact version that your own websites require. Our Linux semi-dedicated hosting services support PHP 4, PHP 5 and PHP 7, which suggests that you will be able to run both older and newer scripts without losing any manual settings or wasting time and efforts attempting to make your websites compatible with the hosting environment. You can change the version through the Hepsia hosting Control Panel and such a change will apply to the entire semi-dedicated account, but you will also be able to pick a different version of PHP for each website hosted in your account by using an .htaccess file.